“flxActAppActivationSend - (0,0,0)” error when activating licence

This error indicates your licence code isn't installed correctly. Within Geneious, try Help→Install FLEXnet (Pro→Install FLEXnet in Geneious 5.6 and earlier), and once its installed put your licence details in under Help→Activate License (Pro→Activate Geneious Pro in Geneious 5.6 and earlier). You need to have admin rights on your computer to install FLEXNet and Geneious.

If you still get this error and you are on a mac, go to the terminal window and type the following (exactly as below all on one line):
sudo mkdir -p "/Library/Preferences/FLEXnet Publisher" ; sudo chmod 777 "/Library/Preferences/FLEXnet Publisher"

If this doesn’t fix it then it is possible that you have the Adobe tools installed and they've already created these directories but with the wrong permissions so do the following in the terminal:

sudo chmod 777 "/Library/Preferences/FLEXnet Publisher/FLEXnet"

That should set up the permissions for Flexnet properly and enable you to activate your licence.

Have more questions? Submit a request

Comments

  • Avatar
    Laurel Yohe

    As soon as launching Geneious 7.1.7 on Mac OSx Mavericks, I received this error:

    Failed to launch FLEXnet licensing service. Try reinstalling Geneious. If the problem persists, please use the Support button in the Geneious toolbar to contact us

    The first tip did not help me (trying to uninstall and reinstall FLEXnet) and I had tried to change the permissions of "/Library/Preferences/FLEXnet Publisher". Realize that you must also change the permissions of the folder within the FLEXnet\ Publisher folder. 

    In terminal, 

    sudo chmod 777 "/Library/Preferences/FLEXnet Publisher/FLEXnet" 

    worked for me.