Completing your Geneious GenBank submission using NCBI Sequin

The Geneious GenBank submission tool is based on the NCBI BankIT tool (http://www.ncbi.nlm.nih.gov/WebSub/?tool=genbank). 

As per the NCBI recommendations for BankIT,

we recommend you use the Geneious GenBank submission tool if:

  • you have a single sequence, or a simple set of related sequences (for example:16S rDNA, ITS/rRNA, or COI sets), or a small batch of different sequences
  • the feature annotation for your sequences is not complicated

NCBI recommend you use their stand alone Sequin (https://www.ncbi.nlm.nih.gov/Sequin/) application if:

  • you have a sequence or sequences that are complex
  • you would like graphical viewing and editing options, including an alignment editor
  • you would like the option to have network access to related analytical tools

If you are preparing more complex sequences in Geneious for GenBank submission then you have the option to export your draft submission from Geneious and validate and complete the submission using Sequin.  

To do this:

  1. First prepare your annotated sequence or sequences in Geneious.
  2. Add the appropriate annotations and qualifiers to all features on your sequence.
  3. Add GenBank Submission-specific metadata to your sequence via the Sequence viewer Info tab (See the GenBank submission tutorial for instructions http://www.geneious.com/tutorials/genbank-submission).
  4. Select your sequence(s), go menu Tools -> Submit to GenBank.  
    1. Click Edit Publisher details and enter all required publisher related information.
    2. Set your Submission type if you are submitting multiple sequences.
    3. Use the drop down menus to map GenBank specific metadata (Country, Specimen voucher, Sequence ID etc) to the appropriate fields.
    4. Set fields for appropriate Molecule type, Genetic code and Genetic location.
    5. Select the option “Include Features/annotations”.
  5. Finally, Check the option to Save a local file (.tar) and go OK.  Do not choose to upload or update a submission.

Any annotations/qualifiers present on your sequence(s) will be parsed by the GenBank submission plugin.  If your annotations do not comply with prescribed NCBI feature definitions (see http://www.insdc.org/documents/feature_table.html) , then you will get an “Invalid Feature Type” error similar to that shown below:  

 

error.png

 

Check and correct any annotations/qualifiers on your sequence so that they comply with NCBI rules.  Then try saving again as a .tar file.  This .tar file can be unpacked using common archive decompression utilities (e.g 7-zip for Windows, simply double-click the file on a Mac).  

The .tar file will unpack to produce an .asn file which can be opened directly using NCBI Sequin (https://www.ncbi.nlm.nih.gov/Sequin/).

All GenBank submission information, including Genbank submission-specific metadata, publisher and publication details, and any annotation information that you added in Geneious will be present and available for further editing in Sequin.  Consult the Sequin manual for more information on how to use Sequin.

Within Sequin, you can use menu Search -> Validate to check your submission meets NCBI specifications. Once you data is ready for submission use menu File -> Prepare submission.  This will output a submission file (.sqn format) that can be emailed to NCBI (Sequin will provide information on where to send the .sqn file).

At this point if you wish you can use File -> Export GenBank to prepare a GenBank flat format sequence that can be imported back into Geneious for viewing.

Note that it is not currently possible to specify a submission release date if using the Geneious GenBank submission tool.   If you choose to complete your submission with Sequin you can use menu Edit -> Edit Submitter information to specify the release date for your sequence.  

 

Have more questions? Submit a request

Comments

  • Avatar
    Dimitrios Skliros

    Thank you very much,

    I contacted genbank and they told that because the genome is not annotated that the best think is to send it to them in fasta format. They will process it then aftewards and create the .sqn file.